[2.64] Unable to use selected item from the inventory

For PC (Windows) specific help with technical issues running the game.
Post Reply
Mextrom
Posts: 17
Joined: Sun Dec 25, 2016 4:53 am

Sun Dec 25, 2016 5:49 am

Hi!

Actually I'm not sure what is the bug related to (inventory or animation). I have selected a bottle from my inventory an hid in the barrel near the Fate and Gusto's cage. I saved the game and when I jumped out of the barrel the character tried to throw the bottle but did not finish the action and freezed (animation freezed). I can run, I can climb, I can interact with any items and characters but there is no animation and I am unable to use selected items (e.g. can't throw a bottle or a stick). Restarting the game does not help :(.

I've attached the save file I hope this will help.

Patch version: 2.64.
OS: Windows 7 (x64)

P.S. how can I upload large gifs? I captured a video (18 seconds, ~11MB) but it is not allowed to upload mp4 files. So I converted it to a gif image but its size is too large (~25 MB).
I'm new to this forum.
Attachments

[The extension save has been deactivated and can no longer be displayed.]

Last edited by Mextrom on Sun Dec 25, 2016 12:12 pm, edited 1 time in total.
Mextrom
Posts: 17
Joined: Sun Dec 25, 2016 4:53 am

Sun Dec 25, 2016 11:44 am

I've added a screenshot with debug information. 'Attacking' flag is always true.
GoaT_2016-12-25_debug_800x500.jpg
GoaT_2016-12-25_debug_800x500.jpg (161.65 KiB) Viewed 1870 times
Mextrom
Posts: 17
Joined: Sun Dec 25, 2016 4:53 am

Sun Dec 25, 2016 12:11 pm

I've found a workaround for this issue. I've changed 'playerAttacking' value in my save file from 'true' to 'false',restarted the game and loaded the save file. So now I can play the game again :).
<TrackedField>
<holdingComponentName>PlayerControl</holdingComponentName>
<fieldName>playerAttacking</fieldName>
<value xsi:type="xsd:boolean">false</value>
</TrackedField>
I think 'playerAttacking' flag is being set incorrectly. It often happens that Tilo attacks (throws a bottle or a stick) when I close some menus. For example when I go to bed ('sleep') a popup window appears in which a can select the time when to wake up. So when I click 'close' button 'playerAttacking' flag changes to 'true'. This happens all the time I close the dialog. I guess the reason is that I set 'attack' to left mouse button.
FakeNina
Posts: 153
Joined: Mon Apr 28, 2014 9:53 pm

Sun Dec 25, 2016 3:24 pm

Hi Mextrom, thanks for your detailed report, and good job finding the workaround! I've passed it on to Seith, and I'm sure he'll be on the case as soon as possible :)

Thanks again,

FN
User avatar
Seith
'Ghost of a Tale' Creator and Developer
'Ghost of a Tale' Creator and Developer
Posts: 203
Joined: Mon May 20, 2013 7:19 am

Mon Dec 26, 2016 11:13 am

Congrats on fixing the bug on your side, Mextrom! :)

In the next release the attribute debug panel will be gone and that issue should be fixed. And Tilo shouldn't throw his current tool when exiting a dialog via mouse/keyboard anymore.
Mextrom
Posts: 17
Joined: Sun Dec 25, 2016 4:53 am

Tue Dec 27, 2016 4:58 am

Thanks! :)
Post Reply