PS4 Controller...

For PC (Windows) specific help with technical issues running the game.
Post Reply
Asuka Jr.
Posts: 4
Joined: Mon Jul 03, 2017 1:03 am

Ok, so I searched the forums for PS4 controller, and the last post about issues using a PS4 controller was made some time ago, so I thought I'd ask for a more current update:

So I'm running the Windows/Steam version 4.34, which I just bought because it looked wonderful, and the ratings were so good, so I figured I'd add Ghost Of A Tale to my list of Early Access/Alpha games I'm supporting the development of...

Decided to get it installed today (bought it yesterday), and since the controls seemed a little...odd, but that it listed having the option to specify a PS4 controller (DualShock 4), and as Steam had finally recognized PS4 controllers the same as Steam controllers, I thought I was home free, as I have had no issues with other controller compatible games (using the Official Sony PS4 controller dongle)... Well, of course that's not exactly true... So since the settings for controllers cannot be reprogrammed to whatever data the system is receiving from the buttons of said controller, I couldn't get the buttons to work correctly, although I thought the sticks worked properly, but the buttons were off (rotated by one position, or so) and the D-pad and Shoulder buttons were definitely off...

So the question is: While the option to set for PS4 controller is in the system, I can assume that the actual controller is still not natively supported...? Sigh.

Is progress being made to do so? Sadly, Sony decided to make the wireless adapter non-compatible with any control mapping program or system (I'd had issue at first in Styx, but that last Steam update fixed that one...) so I can only use the default input data as Sony has decided I should have to. ='(

I'll try to get a usable profile configured on my Logitech G-13 game controller, but I was hoping to be able to just jump in with my controller. Ah, well...

Anyway, thanks for sticking with me through my rambling here...
'Ghost of a Tale' Programming
'Ghost of a Tale' Programming
Posts: 303
Joined: Sat Oct 26, 2013 8:27 am

Sorry, the support of Dualshock4 was created sometimes ago, before Steam announce the support of the PS4 dongle, we did not make additional tests with it.
The game works with the DS4 wired in usb port right now.

But now we will schedule to support the dongle, so stay tuned !
Asuka Jr.
Posts: 4
Joined: Mon Jul 03, 2017 1:03 am

First: Thank you so much for getting back to me so fast! You were certainly faster than most devs, that's great!

So I figured I'd be as thorough as I could be on my reply to your post...

I'm using a: PS4 Dualshock 4 controller, Model #CUH-ZCT2U.
Per your recommendation, this time I connected it directly through USB cable (I know it's a functioning cable, as the controller immediately responds, and changes color according to my presets). Then launched Big Picture Mode (as recommended by Steam to get full usage from my controller), and from there launched Ghost Of A Tale.

Went into the options menu (after starting a new game), and found the O button was the 'active select' button (which should be X). Started changing the controller settings to what I felt they should be, and found the following through trial and error:

O = X
X = [ ]
[ ] = O
/\ = /\

D-Pad is ignored (turns out it's ignored because it's locked... Up = camera up, Down = camera down, Left/Right are apparently set to rotate select item wheel(?) something like that)
Touch Pad = Options
Options = R2
Share = L2

R1 = R1
L1 = L1
R2 = R2
L2 = L2

Once I set things as best I could, I went back into the game, and had full control of movement in the proper directions using the left joystick, as expected...but suddenly realized that I had no camera control on the right stick. Discovered that I had camera left/right rotation with the L2/R2 appropriately, but at first found no up/down camera control, then realized Up/Down is on the D-Pad (as noted above).
Of course this led to an additional problem:
I had set Sprint and Sneak to L2/R2 accordingly, so having the camera rotation lock to those controls made it so that Sneak and Sprint were accessible...but while using sprint, the camera would constantly spin left, and when sneaking, would spin right! :shock:
(oops. Discovered that the sneak/sprint thing only worked during that launch, and I had re-installed DS4Windows during that launch as well... ironically, for a short time there, I had full camera control on right stick, but still forced rotation on L2/R2, but after a reboot of PC and Steam, it went back to no sneak/sprint, no camera stick control)

Tried changing to 'Gamepad Parented Camera' instead of mouse, that didn't help. Then unchecked both settings, and still L2/R2 camera rotation...

So the question is: Is there something I have not/need to do, or have I forgotten something that I should have done (and didn't realize)?

Wow... this ended up being a lot more complicated a reply than I thought it would be at first...

Anyway, thanks again...I'm really hoping you can help me through this, as I really wanna play what's currently available of the game...

(edit) I'm gonna leave the above, as I feel it worthy of leaving up, because it's how my controller acted directly plugged in... but get this: Decided to switch to another game, plugged in my PS4 dongle to use my controller with second game... had issues starting it, then noticed that Ghost Of A Tale was still running. Switched to it, moved the mouse- yep, moves the camera. Moved the right joystick...full camera control! Test other controls, all are now working normally, re-straightened control setup in Options, and now have full controller use! What the heck? Well, whatever.
As of now, I seem to have full controller use through the dongle, without even having to switch to Big Picture. Weird, huh?

Ok, I'm off to play!
Post Reply