Can't progress due to already completed tasks

This is where you can post about bugs and issues that are specific to the Xbox One version of Ghost of a Tale.
Post Reply
User avatar
Posts: 6
Joined: Mon Jul 03, 2017 10:37 pm

I completed a number of quests then thought I made a mistake and when I reloaded an earlier save some of the actions to complete the quests again either couldn't be done at all, or were treated as already done but not checked off so couldn't be completed.

I'm not sure what exactly caused the bug so I'll try to mention all the steps I can [while attempting to not give spoilers and solutions.]

I started the game [build 4.0.0] in a trial.

I talked to the frog two times [the second time caused the game to hang and crash during the autosave at the end.]

I restarted the game and continued the trial.

I escaped the jail [without ever finding the cupboard key.]

I explored and found silas without talking to the blacksmith.

I stole his sypglass before sleeping.

Next I wandered around lost and found all the pieces of the theif costume and found the mice theives.

I talked to them for a while then changed out of the disguise and got the escape quest from them.

I gave them the handkercheif [found it naturally before the quest] and then spoke to rolo and then back to them for the hammer quest.

I went to their old cell and solved the puzzle and got the items.

I unlocked the nearby cell and got the eyepatch [and hat?] causing the skelleton to collapse.

I gave them the stuff and returned the other item.

I got them the passes and the disguise [using lockpick not key] for the cupboard [or was it the chest with the hornet nest....]

They asked for the sypglass but I put it off and they told me to check the footlocker.

I talked to silas and he took the spyglass off me [I couldn't find it anywhere, couldn't pick the footlocker [and saw no key] so reloaded an earlier save from before I met the theives.

========buggy part========

Everything went the same untill I tried to complete the hammer quest. The puzzle was already solved and I could just grab the items, but no-one would recognise that I had them so could not progress.

The nearby cell to their old one still had the skelleton intact and when I took the eyepatch it didn't collapse [so no hat?]

I tried to get silas to go to sleep by sleeping till 3am then waiting near him as talking to him seemed to say he would sleep around dawn, but even by 8am he was still standing there.

I'm now going to try starting over.
User avatar
Posts: 6
Joined: Mon Jul 03, 2017 10:37 pm

Starting a new game fixed the issue with the hat, still working towards the theives cell quest.

However, I made a manual save before grabbing the belt and hat and when I died later on I reloaded it and the same bug occured of being unable to take the hat [luckily I had an autosave I could switch back to after testing that.

So this is a consistant bug where you cannot get the pirate hat if you revert to a save from before you got it.
Posts: 26
Joined: Fri Jun 30, 2017 7:02 am

Hi, I was wondering. Where did you get all the passes, I have two but I am missing one. This is the only thing I left to do for now.
User avatar
Posts: 6
Joined: Mon Jul 03, 2017 10:37 pm

Ones in a table drawer, ones on the floor and ones by a gate.

[Sorry I'm not being clearer but unsure the rules regarding spoilers.]

All of them can be found with clues given to you either by the theives or the blacksmith.
Post Reply